jobs.rice.edu - unable to connect to the website
Incident Report for Rice University
Resolved
This incident has been resolved by the vendor.
Posted Jan 17, 2019 - 09:15 CST
Monitoring
Users should now be able to connect to jobs.rice.edu website. We will continue to monitor.
Posted Jan 16, 2019 - 16:22 CST
Investigating
Users are experiencing connecting to the jobs.rice.edu website. The vendor is experiencing issues with the SSL certificate. Some users have reported that they have been successful using Chrome.
Posted Jan 16, 2019 - 14:59 CST
This incident affected: Other (Announcements).