Baker College | Partial Network Outage
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Nov 23, 2020 - 07:24 CST
Monitoring
Network switch is back online. We will continue to monitor.
Posted Nov 21, 2020 - 20:26 CST
Investigating
We are investigating a partial network outage in Baker College.
Posted Nov 21, 2020 - 19:19 CST