Google Maps access Issues
Incident Report for Rice University
Resolved
This incident is resolved.
Posted May 12, 2021 - 13:58 CDT
Monitoring
Google support has provided a temporary workaround for the issue. We have implemented the workaround just now. It may take some time for the workaround changes to propagate to all users.
Posted Apr 05, 2021 - 12:37 CDT
Identified
Google has identified the issue and is working on a resolution.
Posted Apr 05, 2021 - 11:59 CDT
Investigating
Users are unable to access Google Maps while logged into their Google account.
Try accessing maps.google.com and experience the following message: "We are sorry, but you do not have access to Google Maps. Please log in to your Admin Console to enable Google Maps."
Posted Apr 05, 2021 - 11:52 CDT
This incident affected: Other (Announcements) and Email, Collaboration and Storage (Google Workspace for Education).