Help Desk phone support suspended
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 20:23 CST
Identified
Due to the continuing winter weather situation, the OIT Help Desk is not able to answer phone calls at this time. Please submit all requests via email (helpdesk@rice.edu) or by web form (https://oit.rice.edu/request-help).
Posted Feb 17, 2021 - 08:01 CST
This incident affected: Other (Announcements).