Mail Sytem Issues
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Jan 13, 2020 - 14:36 CST
Monitoring
Earlier today, we had several reports from users receiving SMTP timeouts; were unable to send/receive emails.. The services have been restored. OIT Mail admins are curriently monitoring the services.
Posted Jan 13, 2020 - 11:51 CST
This incident affected: Email, Collaboration and Storage (Cyrus (Campus) Mail System).